微信扫一扫 分享朋友圈

已有 1034 人浏览分享

开启左侧

eNSP交换机怎样配置IP地址

[复制链接]
1034 0
交换机的配置
在聊交换机设置IP的前,首先聊以下方面,这也是为了新手更好的去理解。如果基础的可以直接看VLAN的命令的配置
1、交换机的工作原理
2、VLAN的的作用
3、 VLAN的命令配置

交换机的工作原理
1、学习:把数据包的SMAC(源MAC地址)与接收端口对立,将MAC以及对应的IP地址记录到MAC地址表中。
2、泛洪:把广播报文发送到除接收端口以外的端口。
3、转发:根据DMAC查MAC地址表转发
4、丢弃:收到不识别的报文,丢弃。
交换机的所有接口都属于同一个广播域。在现实生活中,考虑到不同部门的设备可能连在同一个交换机上,又不能进行数据共享。
需要将不同的部分隔离开,数据不互通。下面就介绍解决这问题的方法————VLAN
VLAN
1、VLAN的作用:隔离广播域。使为一个VLAN都是单独的广播域。        共有4096个VLAN,可用VLAN 1~4094个
2、VLAN的接口类型:①access:接入链路需要配置。例:交换机与终端相连的接口
                                                                        ②trunk:干道链路。例:交换机和交换机相连的接口,允许多个VLAN流量通过。
                                                                        ③hybrid:混合链路
3、在不通过的VLAN 里面,设备是不能通信的。除非给交换机配置IP地址,配置完IP以后,可以当交换机来用。


VLAN命令配置
实验拓扑图:

image.png
设置VLAN面对的是交换机的配置
1、给PC机配置IP地址

image.png

2、交换机配置:
①[Huawei]vlan 10 单一创建VLAN
[Huawei-vlan10]
[Huawei]vlan batch 10 20 批量创建,创建了VLAN 10 和VLAN 20
补:VLAN 1是交换机默认的,所有的接口都在VLAN 1 里面。
[Huawei]int vlanif 10 进入创建的VLAN 10 里
[Huawei-Vlanif10]ip address 192.168.1.1 24 给VLAN 10 创建IP地址 配置方法跟接口的配置方法一样

    [Huawei-Vlanif10]dis this 查看配置的IP地址是否配置正确
    - interface Vlanif10 ip address 192.168.1.254 255.255.255.0
    - return
    [Huawei-Ethernet0/0/1]port link-ty access 在PC机相接的接口配置access,
    [Huawei-Ethernet0/0/1]port default vlan 10 允许VLAN 10 的数据通过。
    【完】
    上面配置的VLAN IP,对于PC机来说是网关。
    以上就是对交换机设置IP的步骤
    注:此时的交换机可以当路由器来用了。

格外的小实验

实验内容:
按上拓补图,在交换机上创建VLAN 10 和VLAN 20 ,并依据上图提供的IP地址网段,配置交换机和PC机。
使其不同的VLAN通信。
实验步骤 :
1、创建 VLAN 10 和VLAN 20
2、给VLAN 10 和VLAN 20 创建IP
3、基于接口,设置接口类型
4、设置PC的基本配置,网关设置为交换机VLAN的IP
答案:
交换机的全部配置——————dis cu(可以看所有的配置)
interface Vlanif10
ip address 192.168.1.254 255.255.255.0

interface Vlanif20
ip address 192.168.2.254 255.255.255.0

interface Ethernet0/0/1
port link-type access
port default vlan 10

interface Ethernet0/0/2
port link-type access
port default vlan 20



免责声明:
1,海欣资源网所发布的资源由网友上传和分享,不保证信息的正确性和完整性,且不对因信息的不正确或遗漏导致的任何损失或损害承担责任。
2,海欣资源网的资源来源于网友分享,仅限用于学习交流和测试研究目的,不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。
3,海欣资源网所发布的资源由网友上传和分享,版权争议与本站无关,您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。
4,如果您喜欢,请支持正版,购买正版,得到更好的正版服务,如有侵权,请联系我们删除并予以真诚的道歉,联系方式邮箱 haixinst@qq.com
海欣资源-企业信息化分享平台。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

0

关注

0

粉丝

30

主题
热度排行
回复排行
最新贴子

Archiver|手机版|海欣资源 ( 湘ICP备2021008090号-1 )|网站地图

GMT+8, 2024-2-23 02:57 , Gzip On, MemCached On.

免责声明:本站所发布的资源和文章均来自网络,仅限用于学习交流和测试研究目的,不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。 本站信息来自网络,版权争议与本站无关,您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。 如果您喜欢,请支持正版,购买正版,得到更好的正版服务,如有侵权,请联系我们删除并予以真诚的道歉。